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Welcome!
Thank you for purchasing Tri–BACKUP!

Tri–BACKUP is the quick and simple way to backup, restore and synchronize the files on your Macintosh®. Features include:

• Backup in a variety of modes
• Restoration of files lost to accidental erasure or corruption, or to return to an earlier version of your documents.
• Synchronization of files on different volumes or computers.
• Regularly scheduled backups and synchronizations to your specifications.

Thank you for registering
A registration card is included in the software package. Please complete and submit the form to enable your access to technical support 
and timely notification of updates and product news from TRI-EDRE.

Installation
Simply drag the Tri–BACKUP 4 Folder from the CD-ROM or downloaded archive to your Applications folder. If you downloaded your 
copy of Tri-BACKUP, you may require StuffIt® Expander® to decompress the SIT archive before use. Please read the Read Me file in 
the downloaded folder for the latest information about Tri-BACKUP.

Updates 
Visit our web site at http://www.tri-edre.com to ensure you are always running the most up-to-date version of Tri–BACKUP. Updates 
can be downloaded directly from the site using your assigned serial number. There is no charge for updates to the same main version 
number—your Tri–BACKUP 4 license includes all updates from 4.01 through 4.99 as and when they become available.

Updating to version 4.x
Tri–BACKUP 4 will automatically update and use settings files created in version 4.0. Your new Tri–BACKUP 4 settings files are 
stored in the Tri–BACKUP folder, and a backup copy of the previous settings file is automatically saved in the Tri–BACKUP.prefs 
folder located in the Preferences folder.

Introduction

Note: You may want to 
check the settings for 
each of your previously 
Programmed Actions, as 
new options are available 
under version 4, and some 
existing options have been 
modified.

http://www.tri-edre.com
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Upgrade from version 3 or 2
At first launch, Tri–BACKUP 4 will ask you to select one of your previous settings files, located in the ƒTri–BACKUP.prefs folder 
under version 3, or in the Tri–BACKUP folder under version 2. Tri–BACKUP 4 will then create new settings files automatically.

Uninstalling
To completely remove Tri–BACKUP from your hard drive, quit the application and drag the following items to the Trash:

• The Tri–BACKUP Folder.
• The Tri–BACKUP.prefs folder from the Preferences folder.
• Under Mac OS 9 only, the “Tri–BACKUP Auto” files located in the Startup Items and Shut Down Items folders in the System 

Folder.

Launching and Registering the Software
Double-click the application icon to launch Tri–BACKUP. Enter your serial number at the prompt (sent to you by email, or located on 
a sticker on your CD) to activate all of the features of Tri–BACKUP 4. 

We recommend having Tri–BACKUP automatically launch at your system startup in order to be sure your automatic actions always 
run on time to protect you from data loss:

• Under Mac OS X 10.3 (Panther), choose System Preferences from the Apple menu, then select the Accounts preference, click the 
Startup Items tab, press the Add button, and choose Tri–BACKUP 4 in the dialog.

• Under Mac OS X 10.2 (Jaguar), choose System Preferences from the Apple menu, then select the Login Items preference, press the 
Add button, and choose Tri–BACKUP 4 in the dialog.

• Under Mac OS 9, create at least one Programmed Action within Tri–BACKUP that will be automatically triggered. Tri–BACKUP 
will create a file in the Open at Start Up folder in your System Folder.

Technical support 
Free technical support can be accessed by email, fax or phone. Please have your serial number and software version number handy 
before calling, and be sitting in front of your computer with Tri–BACKUP running.

Contact TRI-EDRE
Please contact TRI-EDRE directly if you have comments, problems or questions about Tri–BACKUP, this user guide or the TRI-EDRE  
web site, or require additional licenses or a site license. 

TRI-EDRE
22 Place de l’Eglise - BP 111
83510 Lorgues, France
Email: contact@tri-edre.com
Phone: +33 4 98 10 10 50
Fax: +33 4 98 10 10 55

Note: Tri–BACKUP is 
required to recover files 
compressed with the 
application.

Note: Keep your serial 
number in a safe place 
to access upgrades and 
technical support and to 
reinstall the software if 
necessary.

www.tri-edre.com
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Under Mac OS X, a user’s access to files and folders depends on the permissions assigned to the items. When a user attempts to read or 
delete a file or folder without the necessary permissions, the system will not allow the operation. This limitation includes Tri–BACKUP, 
since application programs under Mac OS X have the same permissions as the current user. Since many files in the System folder are 
accessible only to the administrator or ”root” user, this can cause backup of items like preference and support files to fail. The solution 
to this problem in Tri–BACKUP is using Administrator Mode.

Activating Administrator Mode
Using a correct administrator-level password, you can grant Tri–BACKUP the authorization to fully access the files on your Macin-
tosh, in order to run a complete backup, or to create a bootable copy of a Mac OS X system. This  authorization applies only to the 
Tri–BACKUP application itself.

On first launch, Tri–BACKUP will offer to save your authorization password, after which you can switch from normal to administra-
tor mode without typing the password. Once the password is saved within Tri–BACKUP, administrator mode can also be automati-
cally enabled and disabled during Programmed Actions.  When running in Administrator Mode, a red circle icon appears in the main 
Tri–BACKUP window and on the application’s icon in the Dock. 

To enable Administrator Mode, do one of the following:

• Choose Backup > Activate Administrator Mode
• Press the Activate Administrator Mode button in the main window

To disable Administrator Mode, do one of the following:

• Choose Backup > Deactivate Administrator Mode
• Press the Deactivate Administrator Mode button in the main window
For added security, choose Tools > Lock Application or press the Lock button  in the main window. Once Tri–BACKUP is locked, 
program settings, Immediate Actions and restorations will be accessible only by entering the correct password. Programmed actions 
will run normally, but no additional actions can be programmed without the password. On first use of this command, you will be asked 
for a new password for the application. This password is set by you and is separate from your normal login or administrator password, 
though it can be the same password if you so choose.

To unlock the application, choose Tools > Unlock Application or press the Lock button  in the main window, and enter your pass-
word.

Administrator Mode (Mac OS X only)

Note: If Tri–BACKUP is 
moved or reinstalled, you 
may have to reactivate 
Administrator Mode.

Note: If you forget your 
password, you will have 
to delete and reinstall the 
application to regain use of 
Tri–BACKUP.
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Actions—Immediate vs. Programmed

Immediate Actions
Use Immediate Actions to quickly and easily run a backup, copy or synchronize files and folders, with very few settings. 

Immediate actions include: 

• Copying a folder or disk
• Backing up a folder or a disk
• Restoring a file, folder, or an entire volume
• Synchronizing a folder or a disk
• Compressing, decompressing or protecting a folder’s content
• Comparing the contents of two folders
• Deleting the contents of a folder.

Programmed Actions
Use Programmed Actions for any tasks you need run often, for those you want to run automatically, and for those where you want to 
exercise fine control over the files and folders affected. Your settings for Programmed Actions are saved and can be run manually at any 
time, or can be set to run automatically at regularly scheduled intervals with no further input from the user.

Programmed Actions include:

• Backup of folders and disks
• Copying of files and folders
• Synchronization of folders and disks
• Compression of files
• Deleting the contents of  folders (for example, to regularly “clean out” cache folder

Basics
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What can be backed up or synchronized?
Tri–BACKUP can manage the contents of any volume attached to your Macintosh. This includes the source and destination volumes 
for a backup, copy or synchronization. Tri–BACKUP handles any file type, including documents and applications, so long as the source 
and destination volumes are currently mounted on your system

Complete Automation
The first requirement for Tri–BACKUP to execute actions automatically is that it is running. Fortunately, even this can be automated. 
To automatically launch Tri–BACKUP at system startup, see Launching and Registering on page 8 above.

Normal Operation
Once you have created a Programmed Action and scheduled it, choose Tri–BACKUP (OS X) > Preferences and check the box marked 
“Automatically launch when actions are to be done.” Once this checkbox is enabled, Tri–BACKUP will automatically launch under 
Mac OS X when necessary, perform the Programmed Action, and then quit until the time set for the next action.. Alternately, you can 
simply leave Tri–BACKUP running at all times. Under the advanced memory handling of Mac OS X, almost no resources are used by 
Tri–BACKUP when it is not the active application.

Under Mac OS 9, we advise you to avoid manually quitting Tri–BACKUP, to ensure your Programmed Actions will execute when in-
tended. Tri–BACKUP creates a file in each of  the Startup Items and Shutdown Items folders in the System Folder,  so that Programmed 
Actions will automatically execute at system startup and shutdown, and quit when necessary. Tri–BACKUP does not install any exten-
sions or control panels under Mac OS 9.

Backup
Tri–BACKUP makes a backup of your data by copying every modified file onto a local disk, a network drive, removables such as Zip 
or Jaz disks, CDs and DVDs. Tri–BACKUP can backup a complete volume or only specific folders. You choose the configuration you 
need.

Tri–BACKUP makes copies of original files for backup. Files are automatically duplicated into the backup location, in much the same 
way as copying them manually. The difference is that Tri–BACKUP preserves owner and permission settings, while the Finder changes 
them during a copy. The directory structure of folders and subfolders is kept intact, which means you can easily verify your backup 
contents, and even restore backups without using Tri–BACKUP (except when backups are compressed—see Immediate Compression 
on page 28 for more). You can also choose from a variety of backup modes, including mirror, evolutive mirror, incremental and more 
(see Backup Modes on page 15 for more)

Backup Destination
In a Backup action, Tri–BACKUP creates a new folder in the destination volume for volume and folder it backs up. For example, if you 
back up your disks “Hard Disk” and “Second Disk” in the “BACKUP” folder on an external hard drive, folders named “Hard Disk” 
and “Second Disk” would be created in the “BACKUP” folder on the external drive.

Note: Under Mac OS X, 
Tri–BACKUP must be 
launched to execute 
actions scheduled for 
shut down. Under Mac 
OS 9, Tri–BACKUP will be 
launched automatically 
at system shut down to 
execute these actions.
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Copying
In a Copy action, files are directly copied to the destination.

Restoring 
File restoration is linked to the backup operation. This allows all files that were copied during backup (or those deleted or modified in 
the source) to be restored in the source folder or volume. Restoration is used to retrieve lost or deleted files, to retrieve a previous ver-
sion of a document, or to rebuild an entire folder or disk. Since Tri–BACKUP makes exact copies of files during backup, you can also 
restore a file manually by copying it directly from the backup location to the source folder in the Finder.

Synchronizing
Tri–BACKUP Synchronization actions are most useful to keep sets of files identical between two Macintoshes, such as a desktop Mac 
in your office and the laptop you carry on the road. In a Synchronization action, Tri–BACKUP compares the contents of two folders 
or disks (including their sub-folders). If a file is present in only one of the folders, it will be added where missing. If a file is present in 
both folders, the newer version will overwrite the older version.

When synchronization is finished, the contents of the two folders or disks will  be identical, with each containing the latest version of 
the files. Tri–BACKUP synchronization is automatic and therefore easier, quicker and safer than opening every folder to make copies 
of files manually.

Multiple configurations
A great advantage of Tri–BACKUP is that you can create and schedule multiple backups or syn-chronization operations, in as many 
configurations as needed, organized in different groups for easier management. These can then  be launched automatically, without 
further user action.

For example, you can schedule:

• An hourly mirror backup of vital documents, to ensure always having an up-to-date copy
• An incremental backup of a frequently-used folder, every evening at shutdown—thus keeping successive versions of reports in 

progress.
• A complete backup of your hard disk, on the first day of every month at 8:00 AM, as a safety backup on a DVD or external hard 

drive.
• Different backups for different days of the week.
• A synchronization of your “Customer File” nightly at 11:00 PM, ensuring that all computers on your network are up-to-date.
• Any other configurations that fit your needs.

Caution: There is no 
warning in a Programmed 
Synchronization Action 
when an older file is over-
written by a newer one. 
If you want to manually 
compare versions before 
they are overwritten, use 
an Immediate Synchroniza-
tion action.
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Although backups can be run manually with Tri–BACKUP, its main purpose is to backup data automatically, without any user interac-
tion. Once configured and scheduled, these operations will do their job without disturbing you. By creating configurations according to 
your needs, you will be able to make full backups as well as specific backups of important folders.

What kind of backup to use?
Tri–BACKUP offers multiple backup possibilities (see Backup Modes on page 15 for more). 

Mirror Backup—This creates an exact copy of your data, allowing you to easily retrieve your work environment after accidental data 
loss. 

Evolutive Mirror Backup—Like a normal mirror backup, this creates an exact copy of your disk or folder. However, on the next execu-
tion of an evolutive mirror backup, when a file has been modified or removed, the evolutive backup saves the previous version prior 
to copying the new one into the backup. This results in Tri–BACKUP saving the evolution of the content, which means you can then 
easily return to a previous version of the files. This backup mode requires more disk space than the normal mirror backup, and uses 
increasing disk space as versions multiply. To control this effect, evolutive mirror options allow you to specify how many versions are 
saved before the oldest are discarded.

Incremental Backup—This creates a new backup in a new folder each time it is executed. This mode allows you to conserve successive 
versions of a document, as well as successive versions of an entire disk.

Archiving Backup—This mode saves the chosen files to the backup destination, but deletes each original file from the source folders 
as it progresses.. Use archiving backups when you want to save older files externally, but no longer need them taking up space on your 
main system. You can also make your archives smaller using Tri–BACKUP compression, and you can secure them using password 
protection.

We recommend combining backup strategies to suit the purposes of your files and folders. For example, you may want to limit incre-
mental backups to important, frequently used files.

Background Backups
Tri–BACKUP will execute backups even while you work in other applications. However, Tri–BACKUP works faster while it is the 
foreground application.

Backup Strategies

Note: Errors or corrup-
tion in source files will be 
created in your backup as 
well. Keeping successive 
or evolutive backups will 
protect you from this pos-
sibility.
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Create configurations for every backup
We recommend setting up several backup configurations to fit your needs. Using multiple configurations optimizes your backup strat-
egy, taking less time and using less space than one full data backup. Also, be sure to regularly execute a global backup to protect your 
entire system.

Backup of several computers over the network
Once Tri–BACKUP has completed a backup of your local volumes, you can save the content of network drives, using a different con-
figuration for each computer as needed. You can also keep a designated server hard drive as a destination for backups of all computers 
on your network, with each computer using its own Tri–BACKUP copy with its own customized configurations.

Backup / Restore / Source / Origin / Destination
Whether you are backing up or restoring, the process of working with your files is directional. Throughout this User Guide, you will 
see references to the “source” or “origin” folder or volume, and the “destination.” Remember that just as a restore is the opposite of a 
backup, so then the origin or source of a restore is opposite to the origin or source of a backup. The source for a backup is your original 
or primary disk. The source for a restore is the backup files you have made. To help ease confusion, when talking about restore opera-
tions, we refer to the source folder as the “source backup.”

Back up your backup!
The safety in backups is having your data stored in more than one location, but backup media can also fail. For the highest security, we 
recommend regularly storing copies of your data on CD, DVD or other high capacity disks designated for backup copies only. You may 
also want to keep two backup sets that are used for alternating backup. For example, using one set for even days and one for odd days 
will ensure you never lose more than one day’s worth of data. Finally, it is best to keep regular backups on completely separate media, 
such as CD or DVD sets, to guard against catastrophic computer failure which can sometimes corrupt even external hard drives.

Always think of your backups as your safe, last resort. Tri–BACKUP is the easy, efficient, unobtrusive way to secure your data. Make 
the most of it!
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As mentioned earlier, Tri–BACKUP gives you several ways to perform your backups. Each method is similarly easy to set up and 
use, and each uses the same basic technique—create a copy of each file, placed in a copy of the original folder structure (folders and 
subfolders). The result is a much easier and efficient process than using simple Finder copies, and the different modes can be chosen 
depending on the goal of the backup.

Finder Backup
You can copy a folder or a volume directly from the Finder to create a backup, though the method is cumbersome and inefficient for 
any more than a small number of files, and makes no easy distinction between versions. However, even backup copies made directly 
from the Finder can be restored efficiently using Tri–BACKUP.

Synchronization
Synchronization can be used as a backup mode, though we do not recommend it for this purpose. This is because synchronization works 
in both directions. Any file that you have removed from your hard disk but previously backed up will be automatically copied back to 
your disk. You can control this effect by using Immediate Synchronization, so that you can precisely control which files to include and 
whether different files are copied in both directions (full synchronization) or only one way. Synchronization is best used to keep folders 
identical between two computers being used to work on the same files, such as a laptop and desktop.

Immediate Backup
An Immediate Backup is best used for a one-time backup, or when you want to preview and control which files will be copied. With 
this mode, you can do a full copy if all items are selected before running the backup.

Immediate Backup performs an “intelligent” backup, copying only files that need it. Using the compress option will reduce the size of 
the backup files.

Programmed Mirror Backup
Use this mode for the simplest backup and possible restoration of a folder or a disk. As its name implies, a mirror backup creates an 
exact copy of a folder or volume. The copy will be updated each time the backup is run, with only modified or new files copied into 
the backup.

Backup Modes

Note: Synchronization 
only copies files that are 
missing or modified. If the 
same file names exist in 
both folders with the same 
modification dates, they 
will not be copied in either 
direction.

Note: Modified files always 
replace older versions 
when a mirror backup ex-
ecutes. If the modified file 
is corrupted, this corrup-
tion will be created in the 
backup as well.
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A mirror backup requires as much disk space in the destination volume as it takes up in the source folder or disk, but the compress op-
tion can considerably reduce the backup size.

The Programmed Mirror Backup is a good way to keep a recently updated copy of your hard disk, which can then quickly restore your 
usual working environment after a hard drive crash or other failure

Programmed Evolutive Mirror Backup
This mode offers the highest level of data security, and an easy way to restore the data.

A Programmed Evolutive Mirror backup is the same as a normal mirror backup, except that in subsequent executions, older versions 
are not overwritten in the backup destination. Instead, when a new version of a file is copied to the backup, the previous version is 
moved to a second level backup folder. This process continues each time the backup is executed, resulting in the possibility of multiple 
versions of each document being saved. 

The advantage to this mode is that the evolution of changes to your source folders is preserved, but at the expense of increasing disk 
space used in the destination volume. Using the compression option can counteract the size needs somewhat, and you can also define 
how many versions are retained, and for how long, before the oldest versions begin to be discarded, using the Options panel.

If you have enough free space (for example, a large external hard disk), this mode is an excellent way to have a complete copy of your 
disk as well as the successive versions of each document. You will be able to use this copy to restore your disk, as well as to choose 
older versions of individual documents.

The evolution of your data in this mode are saved, folder by folder, in special folders named (ƒBACKUP.Evolutive.folder**). These 
folders are invisible, but can be made visible in the Options tab of the action’s settings.

Programmed Incremental Backup
This mode creates a new backup each time it is executed. Each backup is created in a new folder in the destination folder, and is named 
with the date and time of the Backup. The Programmed Incremental Backup mode easily preserves successive versions of a source 
folder’s content, as well as different versions of an entire disk. You can also set an option to delete the oldest backup, so that you can, 
for example, keep the latest states of work done during one week or one month, without having your backup increasing with each 
execution.

Tri–BACKUP’s method of copying files and folders in their original structure creates a huge advantage when you need to restore your 
files from a backup. This system allows you to restore uncompressed backups even when you cannot access the Tri–BACKUP applica-
tion—for example in extreme failure of your main hard drive.

Note: Use the Tools > 
Evolutive Backup data 
command to “clean” the 
evolutive folders by remov-
ing all data from them 
at once. This effectively 
converts the Evolutive Mir-
ror Backup into a standard 
Mirror Backup.

Note: Use the Options tab 
in the Action settings to 
copy only the files modified 
since the last backup. This 
mode creates a relatively 
small sized backup.
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Manual Restoration from the Finder
This is often the easiest way to recover a single file from a backup. Simply mount the volume containing the backup, use Sherlock to 
locate the file you wish to recover, and drag it to the original position on your hard drive. You can also use manual restoration to copy 
an entire disk or folder into a new hard disk, or a newly formatted disk. Keep in mind, however, that any backup files compressed with 
Tri-BACKUP’s proprietary compression scheme cannot be decompressed with Tri-BACKUP being installed on your system.

Using Synchronization to Restore
As with backing up, this is not the best way to restore, but it does allow the simple recovery of a folder or disk. When restoring, it is gen-
erally better to use Immediate Synchronization, so that you can control exactly which files to restore, and the direction of the copy.

Using Immediate Restoration
If you want to easily control the files being restored from the backup, Immediate Restoration is the best way to proceed. All files that 
need to be restored will be shown, and you can select which ones you want to be copy Simply choose Restore a Disk or a Folder in the 
Immediate Actions section, then select the folders or disks, the file to be restored and execute the action.

Using the Programmed Actions Restore button
This mode is the most complete for restoration, allowing maximum control of the files and the versions to be restored. From the Pro-
grammed Actions section, select a backup action and then click the Restore button. If no action is selected first, the origin and backup 
folders will be empty, and you will have to select them, as in the Immediate Restoration action above. Once the list opens, you will see 
the comparison result. Once you select the folders and files you want to restore, click the Restore button to proceed.

You can restore an entire disk or a single file or folder using this mode.

Restore Modes

Note: Copying from the 
Finder can modify owner 
and permissions, and can-
not copy invisible files. To 
preserve owners and per-
missions and copy all files, 
use Tri–BACKUP to execute 
the restoration.
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Most of the features of Tri–BACKUP are available in the main window that appears whenever the program launches. Clicking one of 
the top buttons opens the window to individual panels.

Features are divided into groups accessed using the main buttons across the top of the window:

• The Assistant to help you create Immediate and Programmed Actions
• Immediate Actions options
• Programmed Actions
• Tools including various additional Tri–BACKUP features

Regardless of the main section currently in view, you will also see:

• The red circle icon  that appears at top center when Administrator Mode is activated.
• The lock button  at lower left that allows you to lock or unlock Tri–BACKUP with a password. When locked, only the already 

defined Programmed Actions are available.
• The Activate/Deactivate Administrator Mode button at lower center allows you to change the current permissions mode for Tri–

BACKUP.
• The www.tri-edre.com hyperlink at bottom center that accesses the TRI-EDRE web site in your default web browser

The Main Window

www.tri-edre.com
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Assistant
The Assistant gives you a simple, step-by-step process to create some of the most common Tri–BACKUP actions. Select the type of 
action in the pop-up menu, then follow the instructions displayed in successive panels. You can move forward in the process or return 
to an earlier step at any time, using the arrow buttons at the right side of the window.

Immediate Actions
Buttons in this panel open immediate action windows (copy, backup, restore, synchronize, compress/decompress, etc.)

Programmed Actions
Use the Programmed Actions panel to create, edit and schedule actions, manually execute them, restore, etc. The list displays the 
Programmed Actions that have been created, including their type, name, and next scheduled run time. The list can be set to display all 
actions, or only the actions assigned to a given group (using the pop-up menu at the right end of the column titles).

The next scheduled action is shown in the list in blue with an alarm clock icon, while the currently running action is shown in red with 
a round, red icon. The actions in the queue, waiting to be run, are displayed with a round, grey icon.

Groups of Programmed Actions
Action groups allow you to organize and regroup your actions into logical sets—for example, you could create “LOCAL BACKUP” 
and “SERVER BACKUP” groups to separate backups to be run on local drives from those meant for servers.

There are 10 groups available, and their names can be changed using the 
Groups pop-up menu. Each action can be assigned to one of the groups.

Controls
From the main window, you can:

• Create a new action ( )
• Modify or delete ( ) an existing action
• Suspend ( ) the triggering of actions for a set period (for example, if 

you do not want backups to run during the next 30 minutes). If an action 
is currently running, it will be paused during this time.

• Manually run a Programmed Actions, by selecting it and clicking the 
Run Now button.

• Quickly activate or deactivate selected actions (Command-T).
• Create a file to launch actions from the Desktop, by selecting an action 

and choosing Action > Create a file to run selected Actions.
• Open the Restore window by clicking the Restore button (see Immediate 

Restore on page 26).

Note: Actions can also be 
accessed using the Actions 
menu. If a Programmed 
Action is selected in the 
main window, and an Im-
mediate action is chosen 
from the Actions menu, 
the settings (origin and 
destination) of the selected 
programmed are used for 
the immediate action.
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Tools
Options in this panel include:

• Compare Two Disks or Folder—to check the content

• Partition a Folder’s Content—from a single folder to a series of smaller 
ones

• Regroup Folder’s Content—to create a single folder from the content of 
a series of smaller ones

• Modify Properties—to adjust owners and permissions

• Check Volume Access—to test permissions on a volume

• Information—to reveal information about files and folders

• Latest Files—to see a log of recent executed actions

• Errors—to see a log of recent errors during action execution

• Common Filters—to access the common filter editor

• History—to see a history of events in Tri-BACKUP

• Browser—to open the Backup Browser window

For more information, see Tools on page 42

Action Progress window
When one or more actions execute, either because they were manually 
launched or were scheduled, they are displayed in an Action Progress win-
dow. The current action is displayed with its progress, the name of the folder 
currently being scanned, the last file copied, the total number and size of the 
copied files, and the free space remaining in the destination volume.

Click the:

• Suspend button  to pause execution of all actions for the time period 
you specify

• Stop button  to cancel the action in progress, 
• Skip button  to skip the current folder and proceed to the next.

Select a pending action in the queue and click the:

• Remove button  to remove the action from the queue—the action itself is not deleted or altered.
• Run Last button  to move the action to the bottom of the queue.
• Do Not Eject button  to override settings to eject the destination volume after the action is complete. The name of the remote 

volume is displayed next to the button.
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Open the Preferences window by choosing Tri–BACKUP (OSX) > Preferences in Mac OS X, or Edit > Preferences in Mac OS 9.

The general preference options are

• Iconize—If this option is checked, a small Tri–BACKUP icon is shown at the top right of your screen whenever another application 
is active, and the Tri–BACKUP windows are hidden.

• Icon in Dock only—Under Mac OS X, Tri–BACKUP is completely hidden when it is in the background, but its icon remains visible 
in the Dock.

• Show splash screen at startup—If this option is checked, the splash screen is displayed when Tri–BACKUP is launched.

• Progressive effects—If this option is checked, window resizing is progressive.

• Do not display tips—If checked, Tri–BACKUP tip alerts will not be shown.

Preferences
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Options for Programmed Actions are:

• Automatic Launch when actions are to be run (Mac OS X only)—If checked, Tri–BACKUP will quit if no action is scheduled to 
run in the next five minutes, and will relaunch automatically when the next action is scheduled to run.

• Quit when all actions of current day are completed—If checked, Tri–BACKUP will quit once all Programmed Actions scheduled 
for the current day are finished.

• Don’t show invisible files while copying—If checked, invisible files are represented by “...” in the main window progress area when 
a Programmed Action is running. This can be useful to conceal your invisible files during the backup process.

• Eject inserted volumes—If checked, Tri–BACKUP automatically ejects destination volumes when they are full.

• Create a text log of copied files—If checked, Tri–BACKUP save a list of all files copied in a Programmed Action. The log file is 
saved in the ƒTri–BACKUP.logs folder, and is named using the Action name and the run date. A separate log file is created each 
time an action runs.

• Display a Report for each action—If checked, Tri–BACKUP displays a short report after running a Programmed Action, showing 
the number of files copied, deleted, etc.

• Display Reports for the latest errors—If checked, Tri–BACKUP displays a short report at startup containing the latest actions with 
errors.

• Delay before running actions—Enter a time delay in seconds in either or both of the startup and shut down fields, in order for 
Tri–BACKUP to pause for that time period before executing actions. This option allows you to have Tri–BACKUP launch at system 
startup, but to delay running actions until other applications—such as antivirus software—have completed their tasks.

• Remove from history after—After each Programmed Action executes, Tri–BACKUP saves the results in a list that can be displayed 
by choosing Windows > Show History. Data in the list is deleted when it is older than the number of days set in this field.
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Immediate Actions offer a quick and easy way to begin an operation (backup, synchronization, etc.), or to compare two folders.

Click the icons at the left of the action descriptions to open windows for each type of action—Copy, Backup, Restore, Synchronize, 
Compress/Decompress, Password Protect and Delete. Several Immediate Action windows can be opened at the same time, with actions 
running simultaneously as well.

The windows of the different Immediate Actions are each organized in the same way:

A

B

C

D

A A filter and settings area at the top of the window.
B A selection area to choose the target folders or disks.
C A list displaying files and folders that will be processed by the action.
D One or more buttons to execute the action.

Immediate Actions
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Actions Menu vs. Main Window
The source and destination folders or volumes for a new Immediate Action are automatically preset if

• You select a Programmed Action in the main window, then choose an Immediate Action from the Actions menu—the new Immedi-
ate Action will be preset with the source and destination of the selected Programmed Action:

• You have a current Immediate Action window open with a source and destination, and choose a new Immediate Action from the 
Actions menu—the second Immediate Action will be preset with the source and destination of the original Immediate Action.

Common Immediate Actions Settings
These are the methods and settings that are common to each of the Immediate Actions.

Filter Settings

The top of each Immediate Action window contains the same settings options, which change the way lists are displayed and how items 
in the list are treated when the Action executes. 

If the box is checked

• .DS_Store—Display and process normally hidden Mac OS X folder settings files

• Aliases—Display and process aliases.

• Invisibles—Display and process invisible files and folders.

• Filter Selection—This pop-up menu applies the common and specific filters from a chosen Programmed Action to the current Im-
mediate Action. Only Programmed Actions with filters will appear in the menu.

• Documents only—Display and process documents only (applications are ignored).

• Evolutive Data—Display the additional data folders containing older file versions specific to an Evolutive Backup. If unchecked, 
these older versions ignored.

• Copy UID/GID—Copy the owner, group, and permissions. If unchecked, file and folder copies will be set with the Finder’s default 
values.

• Replace Newer—Allow files to be replaced by older versions (i.e. older modification dates). By default, newer files replace older 
files.

• Remove Missing—If a file exists only in the destination, it will be deleted during the Action. For example, if a file is backed up, then 
later deleted because it is no longer needed, it will still exist in the backup. The next time the backup action runs, this checkbox tells 
Tri–BACKUP to delete the backup copy as well.

• Compress files—File copies are compressed in the proprietary Tri–BACKUP compression format.

Click the Help  button to display these definitions, and a description of the icons that can be displayed in the list.

Note: Some of theses 
settings may be disabled 
for certain Immediate Ac-
tions. The settings as they 
appear when the window 
first opens are the ones 
we recommend for that 
Action.
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Choosing Folders and Disks
To choose source and destination folders, either drag the folders to the left and right selection wells, or click the wells and choose fold-
ers from the Open dialog that appears.

• The Swap button  exchanges the folders (the left one moves to the right position and vice versa.

• The Rescan button  updates the list by rescanning the folders’ contents.

Display options
• Differences only/Display All—You can choose to display all items in the list, or only the files and folders needing to be copied (or 

deleted if Remove Missing is checked in the options).

Immediate Backup
A backup copy of a folder’s content (the folder to be backed up) is made inside the backup disk or folder. The backup will make an 
exact copy, including all folder and subfolder structures.

Once you have chosen the folder to backup and the destination, Tri–BACKUP will analyze their content, and display the files and fold-
ers needing backup.

This action will not change the contents of the source folder—only the backup content is modified.

Note: To choose invisible 
items, Option-click the 
selection well.

Note: Items that are iden-
tical in both source and 
destination are inactive 
and cannot be selected in 
the list.
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General options for Immediate Actions include:

• Replace Newer—allows older files from the source folder to replace newer files existing in the backup.

• Remove Missing—allows files to be deleted in the backup, if they are not found in the source folder.

Options specific to Immediate Backup are:

• Copy content—Tri–BACKUP will copy the content of the source folder to the destination. In the example above, the content of the 
“Documents” folder will be copied inside the BACKUP folder.

• Backup in subfolder—Tri–BACKUP will copy the folder itself as well as its content. In the example below, the content of the Docu-
ments folder will be copied within a folder named Documents, created if needed in the BACKUP folder.

Running a Backup
Once source and destination folders are chosen, Tri–BACKUP compares the contents and displays the differences between them. Select 
the files in the left source list to be backed up, then click the Backup button to begin. Tri–BACKUP will show the progress, and as the 
files are copied, “OK” will replace the arrows between the lists. “ERR” will be displayed for files which fail to be copied successfully, 
most often due to permission errors.

Checking First
To verify that a file can be correctly copied, select it in the list and click the Check button. Tri–BACKUP will test to be sure the file 
can be read and properly copied to the destination, and that the permissions can also be correctly copied. A result window appears on 
completion.

Immediate Restore
Restoration is simply the reverse of a backup. Tri–BACKUP compares the files from the backup destination with the content of the 
source, to decide which should be copied back to the source.

General Options for Immediate Actions include:

• Replace Newer—allows older files from the backup folder to replace newer files existing in the source folder being restored.

• Remove Missing—allows files to be deleted in the restored source folder, if they are not in the backup folder.

Options specific to Immediate Restore are:

• Restore content—Tri–BACKUP compares the content of the source folder in the content of the backup folder. In the example 
above, the content of the BACKUP folder will be compared with—and copied to—the content of the  Project A folder.

• Restore from a subfolder—Tri–BACKUP compares the content of the source folder with its copy inside the backup. In the example 
above, Tri–BACKUP looks inside the BACKUP folder to the find the Project A folder that matches the Project A source folder.
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Once source and destination folders are chosen, Tri–BACKUP compares the contents and displays the differences between them. Select 
the files in the right list to be restored, then click the Restore button to begin. Tri–BACKUP will show the progress, and as the files are 
copied, “OK” will replace the arrows between the lists. “ERR” will be displayed for files which fail to be copied successfully, most 
often due to permission errors..

Immediate Copy
This Action creates a mirror of a source folder or disk in a destination folder or disk. Unlike the Immediate Backup, no selection of files 
is necessary or allowed—all items are copied except those which match the active filters for the Action.

Note: This action does not 
alter the content of the 
backup folder. Only the 
content of the restored 
source folder is modified.

This action does not 
change the content of 
the source folder. Only 
the destination content is 
modified.
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Immediate Synchronization
Synchronization compares the content of two folders, and displays the differences (files modified or missing). If Backup is the process 
of copying files from source to destination, and Restore is the process of copying from destination to source, then Synchronization is 
like doing both at once—it enables you to synchronize two folders by copying files in both directions, which makes it best used for 
keeping active folders identical. Since this action can change the content of both folders, it is not the best way to secure backup data.

Once you have select the folders to synchronize, you can chose the folders and files to be copied, then click Synchronize to run the Ac-
tion. Files missing from one folder are replaced with copies from the other. Newer versions of files in one folder replace older versions 
in the other. Where the file exists in both folders, you can also force Tri–BACKUP to copy in only one direction, by clicking one of the 
Copy buttons under the left or right columns, depending which direction you want to force. When the Synchronization is completed, 
the contents of both folders will be identical.

Immediate Compression/Decompression/Protection
• Use the Immediate Compression option to recover disk space from a backup Action performed without compression.
• Use the Immediate Decompression option to restore files from a backup Action performed with compression.
• Use the Immediate Protection option to password protect files already backed up.
• Use the Immediate Unprotect option to restore files previously backed up using password protection.
During compression, each file is processed separately, creating one compressed file for each original, all using the same file names as 
the originals. During decompression, the original file will replace the compressed version.

It is important to note that Tri–BACKUP uses a proprietary compression format, and must be installed to recover compressed files. 
Since file names are not changed when a file is compressed, the only way to tell compressed from uncompressed files is the specific 
icon Tri–BACKUP creates when it compresses a file. If Tri–BACKUP is removed from your Macintosh, this custom icon may not be 
displayed. This can lead you to mistake a compressed backup file for a corrupted original, because its owner application will not be 

Note: You can use 
Synchronization to easily 
compare the differences 
between two folders.

Caution: Protected files 
are encrypted. If you forget 
the password, you will not 
be able to recover the file. 
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able to open it. For example, if you compress a file called MyDocument.doc, uninstall Tri–BACKUP and then double-click the file, 
Microsoft Word may attempt to launch the file, and fail. Once you reinstall Tri–BACKUP, double-clicking the file will decompress it 
and make the document readable again.

To run these actions, choose the source folder, select the files in the list to be affected, choose the required function from the pop-up 
menu at the bottom, then click the button (Compress, Decompress, Protect or Unprotect, depending on the pop-up menu choice).

Delete a Disk or Folder’s Contents
Select a source folder, choose the files you wish to erase in the list, and click the Delete button.

Caution: Deleted items 
are erased, not merely 
moved to the trash. There 
is no undo for this action, 
and files will be irrecover-
able after deletion.
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Anytime an Action requires much setup, is regularly used, or needs to be set to run at a specific time or times, the answer is to create a 
Programmed Action. All settings will be saved, and once created, the Action will execute as scheduled, without any intervention.

You can create as many Programmed Actions as you want, for automatic Backup, Copy, Synchronization, Deletion and Compression. 
Settings and schedules are specific for each action, and the main Programmed Actions window displays a list of all current Programmed 
Actions, sorted by group.

• Click the New Action button  to create a new Programmed Action. 

• Double-click an existing action to edit its settings.

• Select an action in the list and click the Delete button  to remove it.

• To run Programmed Actions manually, select one or more from the list, 
and click the Run Now button at lower left.

• To suspend the execution of Programmed Actions for your choice of 
duration, click the Suspend button  at the upper right.

If you have an action or two which you often run manually, you can assign 
them to the two Run shortcut buttons  at lower center. Simply select an 
Action, then click one of the shortcut buttons to assign that action to it. Once 
assigned, you can also run that action by choosing Backup > Launch Action 
of Shortcut 1 or Backup > Launch Action of Shortcut 2.

Programmed Actions
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Creating a Programmed Action
Click the New Action button at top left or choose Backup > Create New Action (Command-N) to open the New Action dialog. The 
various possible Action settings are grouped into separate tabs along the top of the dialog, including:

• Mode—Action name and type, the group to which it will be assigned, and whether it requires Administrator Mode or not.

• Items—Source and destination folders and files, depending on the chosen Action Mode.

• Options—Settings specific to the chosen action, such as whether to compress the backup files or partition the backup into folders 
suitable for burning on CDs.

• Trigger—Set a schedule for automatic execution of the Action. You can also set a checkbox here to prevent the action from being 
run manually..

• Filters—Set rules for files to be excluded from the Action. You can exclude all aliases or invisible items, or drag a specific folder 
into the list. Use filters to skip certain files or folders—such as temporary files. If the backup source is your Home folder, you could 
drag your Sites folder into this list in order to backup everything in your Home folder except the Sites folder.

• Links—Operations that can be executed at the beginning or the end of the action, such as running AppleScripts, opening documents, 
displaying custom alerts you create, or launching another Action.

Mode Panel

Title
Give the action a descriptive name so you can easily keep track of it 
in the Programmed Actions list afterward.

Group
You can choose to assign the Action to one of the existing groups, for 
even easier organization in the main window.

Mode menu

Choose the type of action you wish to create:

• Alert and Launch—to display a message and/or launch a file or script, without running a Tri–BACKUP Action first. You can use this 
mode to warn an end-user of an Action about to be run, or to prepare an operation.

• Direct Copy—to copy the complete contents of a disk or a folder into the destination disk or folder.

• Mirror Backup—to create an exact copy of a folder or a disk. 

• All files are copied to the backup. 

• Any modified or new file is copied to the backup, replacing the previous version. 

• All unchanged files remain untouched in the backup. 

• If the backup volume is full, Tri–BACKUP will ask for another volume to continue the backup.
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• Evolutive Mirror Backup—to create an exact copy of a folder or disk, but also save older versions of files in successive executions. 

• All files are copied to the backup. 

• Any new file is copied to the backup. 

• If Tri–BACKUP finds a modified file, with different versions in the source and backup folders, the previous backup version is 
moved to the “second level” backup and the new version is copied to the “main” backup. 

• All unchanged files remain untouched in the backup. 

• Tri–BACKUP also saves the content of the original folder. 

• Incremental Backup—to create a new backup each time it is executed, in a folder whose name contains the date and time of execu-
tion. If the backup volume is full, Tri–BACKUP asks for another volume and continues.

• Archiving—to create a backup of a folder or a disk, and then to delete each backed up file from the original source folder.

• Synchronization—to make two folders identical, by copying missing files and replacing older versions of files with newest ones.

• Compression/Decompression—to automatically compress, decompress or password protect the contents of a folder. For example, 
you could set up a “watch” folder as the source for the Action, and schedule it to run every three hours. After that, you can simply 
drop files inside that folder when you want them to be compressed, but not necessarily backed up to another volume right away.

• Delete—to automatically erase all files and folders in a folder or disk. This can be used to create a self-emptying “trash” folder.

Administrator Mode (Mac OS X only)
Common to all Action types is the option to change Tri–BACKUP either into or out of  Administrator Mode before running the Action.
In certain cases, it is better to activate Administrator Mode, such as when you need to access an entire hard drive on your system. Other 
times, it is preferable to NOT be authorized as an administrator, such as when you need to access a server. You may need to change this 
setting if you find you are getting a lot of permission errors after running a given action.

Items Panel
To add folders and volumes to the source and destination wells, either 
drag them in or click the well and use the Open dialog. To add items 
to the lists, drag them into the list or click the Add button at the top of 
the scrollbar, and use the Open dialog.

The action type determines the items which are chosen:

• Direct Copy—Choose the source folder or disk to copy, and the 
destination folder or disk.

• Backup and Archiving—Choose a list of disks, folders and files, and a single destination folder to which they will be copied.

• Synchronization—Choose the two folders to synchronize, and the mode:

• In two-way synchronization, the most recent files are copied in the other folder, regardless of direction.
• In a one-way synchronization, files from the left folder are copied to the right folder. Files which no longer exist in the left source 

folder can be removed from the right folder during synchronization, or left alone. Note that a one-way synchronization often 
results in the two folders NOT having identical contents.

• Compression and Deletion—Choose the folder to be processed.

Note: Exclusions are deac-
tivated in Delete mode, but 
you can still create filters 
to modify the action.

Note: An Evolutive Backup 
must be done to a single 
volume. It cannot be split 
between multiple cartridg-
es or disks. If the destina-
tion disk is full, the backup 
stops.
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About unmounted volumes
Under Mac OS 9, Tri–BACKUP will automatically mount any volume previously used by a Programmed Action, and then eject the 
volume once the action is completed. Under Mac OS X, this feature is facilitated through the creation of aliases.

To set up a list of volumes which Tri–BACKUP should access: 

1 Mount the volumes
2 Create an alias to each volume by selecting the volume in the Finder and then choosing File > Make Alias
3 Move or copy the aliases to the volumes to the Alias folder inside your Tri–BACKUP folder. Make sure the aliases have the same 

name as the volumes to which they refer—remove “alias” from the name if necessary. Once you complete this step, Tri–BACKUP 
will attempt to mount the volume using its alias, if it cannot be found on the local network.

The Alias folder is created in the same folder where Tri–BACKUP resides, the first time you launch the application. If Tri–BACKUP 
is loose inside your Applications folder, then the Alias folder will be there too.

Options panel
The options which appear in this panel are specific to each action type. 
The list below describes the options available for different modes.

Alert and Launch of File or Script
There are no options for this mode

Direct Copy
• Copy owner and group (UID/GID)—Tri–BACKUP copies owner 

and group from source files to destination files.

• Delete files missing from the source—A file in the destination 
with no equivalent in the source folder will be removed. This op-
tion ensures your copy is exactly the same as the original folder, with files that were deleted in the source automatically deleted from 
the copy as well.

Mirror Backup
• Copy owner and group (UID/GID)—Tri–BACKUP copies owner and group from source files to destination files.

• Compress files—Backup files are compressed using Tri–BACKUP’s proprietary compression format.

• Protect with password—Each backup file is compressed and protected with a password. 

• Delete files missing from the source—A file in the destination with no equivalent in the source folder will be removed. This option 
ensures your backup is exactly the same as the original folder, with files that were deleted in the source automatically deleted from 
the backup as well.

• Allow replacement of newer files by older ones—Existing backup files are normally older or the same age as the source files, the 
exception being when you reinstall files or restore an older version. This option ensures these files will be copied to the backup.

Note: To add invisible 
folders or volumes, Option-
click the source or destina-
tion well.

Note: If no destination 
folder is chosen in setting 
up a Programmed Action, 
Tri–BACKUP will ask for 
one when the Action is 
executed.

Caution: If you acciden-
tally delete a file in the 
source folder, the Delete 
Missing Files option will 
delete the copy you could 
otherwise use to restore it.
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• Partition the backup...—Use this option to easily divide a large backup into parts suitable for smaller capacity media—for example, 
to backup a large hard drive to CDs. The backup will be split into multiple folders numbered in series. The size of each folder will 
not exceed the size you specify in this option, unless a single file exceeds that limit.

Evolutive Mirror Backup
• Copy owner and group (UID/GID)—Tri–BACKUP copies owner and group from source files to destination files.

• Compress files—Backup files are compressed using Tri–BACKUP’s proprietary compression format.

• Protect with password—Each backup file is compressed and protected with a password. 

• Visible Folders—Evolutive Backup save the previous backup versions of any modified document. These versions are stored in spe-
cific invisible folders within each backup folder. This option makes these special folders visible.

• Backup Size Limitations—Because Evolutive Mirror Backups store older versions of backup files, the size of the backup can in-
crease every time it is executed. These options allow you to control these size increase by determining how Tri–BACKUP deals with 
the oldest versions:

• Delete old files after—Older versions are deleted after the number of days you specify.

• Only Conserve—The maximum number of versions you specify for each file will be saved, after which the oldest will be deleted 
when a new version is added.

• Leave Free Space on Disk—Defines the minimum amount of free space in megabytes which must remain on the destination volume 
after the backup is executed. If space runs low, oldest versions of files are removed automatically.

Incremental Backup
• Copy owner and group (UID/GID)—Tri–BACKUP copies owner and group from source files to destination files.

• Compress files—Backup files are compressed using Tri–BACKUP’s proprietary compression format.

• Protect with password—Each backup file is compressed and protected with a password. 

• Delete Previous Backup after—A new backup folder is created each time an Incremental Backup action is executed. Previous 
backups will each be deleted after the number of days you specify here. The most recent backup is always retained, regardless of its 
age.

• Partition the backup...—Use this option to easily divide a large backup into parts suitable for smaller capacity media—for example, 
to backup a large hard drive to CDs. The backup will be split into multiple folders numbered in series. The size of each folder will 
not exceed the size you specify in this option, unless a single file exceeds that limit.

Archiving
• Copy owner and group (UID/GID)—Tri–BACKUP copies owner and group from source files to destination files.

• Compress files—Backup files are compressed using Tri–BACKUP’s proprietary compression format.

• Protect with password—Each backup file is compressed and protected with a password. 

• Partition the backup...—Use this option to easily divide a large backup into parts suitable for smaller capacity media—for example, 
to backup a large hard drive to CDs. The backup will be split into multiple folders numbered in series. The size of each folder will 
not exceed the size you specify in this option, unless a single file exceeds that limit.

Note: Tri–BACKUP will 
never remove all versions 
of a backup file—at a 
minimum, the most recent 
version will be retained.

Caution: If you lose or 
forget the password for a 
protected file, you will not 
be able to recover it.

Caution: Use with care! 
Source files are deleted 
after an Archiving action. 
For this reason, we advise 
not archiving files unless 
they are already backed 
up. Once you are sure the 
archive is secure and sure 
you no longer need source 
copies, you can delete the 
backup.
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Synchronization
• Copy owner and group (UID/GID)—Tri–BACKUP copies owner and group from source files to destination files.

Compress/Decompress
• Choose from the pop-up menu whether the target files are to be compressed or decompressed, with password protection added or 

removed.

Delete
There are no options for this mode.

Trigger Panel
The Trigger panel allows you to quickly and easily choose when the 
Programmed Action will automatically execute, and also displays, at 
the bottom left, the last time the action was executed, and the next 
time it is scheduled to be executed.

• Prevent this action from being run manually—This option deac-
tivates the Run Now button in the main window for this action, so 
that it will only run when scheduled in the Trigger panel.

• Automatic Triggering—Use this option to globally deactivate or 
activate automatic scheduling with this option. For example, if 
you have a complex set of run times but want to override them 
while you’re away on vacation, unchecking this box will put the 
action “on hold” while still remembering your schedule for later 
use. Deactivated actions can still be run manually from the main 
window, unless the “Prevent this action...” checkbox is enabled.

• Trigger—Choose an option for a repeating cycle of automatic execution, with options to refine the menu choice appearing below:

• Every Hour, Every 3 Hours, When Volumes Mount, Every Startup, Every Shut Down—No additional options

• Every Day, Every Even Day, Every Odd Day, First Day of Month, Last Day of Month—Click the time bar to create execution 
times within each day, using 0 to execute at startup, and 24 to execute at shut down.

• Weekly—Click the time bar to create execution times within each day of the week, using 0 to execute at startup, and 24 to execute 
at shut down.

• Every Month—Enter the days of the month on which to execute (1, 10, 15, etc.), then click the time bar to create execution times 
within each of those days, using 0 to execute at startup, and 24 to execute at shut down.

• Permanent—This special setting tells Tri–BACKUP to execute the action every 30 seconds if the application is not busy, and at 
startup and shut down. This setting is useful for creating automatic backup copies of crucial documents in progress.

Note: You can also acti-
vate or deactivate actions 
by selecting them in the 
main window, then choos-
ing Backup > Activate/De-
activate Selected Actions.

Note: If, for any reason, a 
Programmed Action cannot 
be run at its scheduled 
time, it will be executed as 
soon as possible.
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The Filters Panel
This panel defines which files and folders which should be ignored or 
included, based on their characteristics.

Predefined Filters
The top area of the Filters panel allows you to quickly filter common 
global characteristics. For each type of action, Tri–BACKUP presets 
these options with their recommended settings—turning down the 
disclosure arrow at top left allows you to override the defaults as you 
prefer. 

• Exclude Aliases—No alias files will be included in the action.

• Exclude Invisibles—No invisible files will be included in the ac-
tion.

• Exclude .DS_Store Files—The action ignores these invisible files 
used by Mac OS X to store folder settings.

• Documents Only—The action ignores all files unless they are doc-
uments.

• Only files modified since the last execution—The action only 
includes files with a modification date more recent than the time of the last execution of the action. The date itself is shown on the 
right side in blue.

• Use Common Filters—In addition to the specific filters you add in this window, you can enable this checkbox to include global 
common filters which are defined by choosing Tools > Edit Common Filters (see <> on page <> for more).

• Use Specific Filters—If checked, the action is limited by the filters you add to the list below it. This checkbox allows you to set up 
as many filters as required, but still run the action without them when necessary.

Specific Filters List
A file or a folder must match all criteria of each filter to be accepted for the action. For example, if the first filter excludes files larger 
than 1000 Kilobytes, and a second filter excludes files modified after 1/1/2004, then a 50 Kilobyte file modified on February 12, 2004 
would not be processed, because it failed to pass BOTH filters. Tri–BACKUP filters are powerful, so you should always take care to 
ensure they do not combine in unexpected ways.

• To delete an existing filter, select it in the list and click the Delete  button at the top of the scrollbar.
• To edit an existing filter, double-click it in the list
• To add a new filter, click the Add  button at the top of the scrollbar and set the options in the Filter Editor, or drag a file or folder 

into the list, and then double-click it to adjust the options:

Note: The setting of the 
last execution date can be 
changed by clicking the 
date, which is displayed in 
blue and underlined.
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Filters Editor
The Filter Editor window allows you to quickly create powerful new filters, or edit existing filters, simply by filling in a few fields.

File and Folder Inclusion/Exclusion:

• Mode—Choose from the menu to determine if this filter will act on files or folders, and whether it will exclude items that match its 
settings, or only include those items that match its settings.

• Name/Path—This menu determines if the filter depends on the item’s name or path to it—for example, files whose name starts with 
“Photo,” folders whose path ends with “Sites” (to include the multiple web sites stored on a single drive).

• Label is—Limits the filter to items marked with a specific Mac OS label color.

File Inclusion/Exclusion:

• Creator/File types—These Mac OS codes can signify what kind of file it is, and what application is used to open it. You can type 
the four-character codes directly into the fields, or use the Choose button to select one which already has those characteristics. For 
example, selecting an Adobe Photoshop® PSD file would insert “8BIM” into the Creator type, and “8BPS” into the File type. This 
would limit the filter to including or excluding PSD files “owned” by Photoshop.

• Size is—Limits the filter to files larger or smaller than the size you set.

• Modified—Limits the filter to files modified before or after the date you set.

Folder Exclusion only:

• Exclude if folder is empty—Limits the filter to folders which contain files and/or other folders. By default, Tri-BACKUP will copy 
empty folders to backups.

a
Note: Empty fields will not 
be used for filtering.
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Links Panel
This panel allows you to link additional files and behaviors on your Macintosh to Programmed Actions within Tri–BACKUP. Before 
or after executing the action, you can alert the current user, open files, run another Tri–BACKUP action, and even use various links in 
series. 

Possible combinations include:

• Define two different custom alerts which must be read and confirmed before the action runs, after it is completed, or both. For ex-
ample, you might want to warn an end user on your network that their Old Documents folder is about to be archived.

• Play an alert sound, to get the user’s attention, before and/or after the action runs. 
• Launch either or both of two specified files, before and/or after the action runs. Possibilities include running applications or Apple-

Scripts, or simply opening documents.
• Execute another Programmed Action, in order to link two related actions and have them always run in series.
• Shut down your Macintosh, after the action is complete—useful when you want an action to run at the end of the day unattended.
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Restoring is a way to recover a lost or damaged folder or disk, returning it to a previous, more useful state. There are many methods you 
can employ to restore your files, including using Immediate Actions “in reverse” (see Restore Modes on page 17 for more).

It’s important to note that you are never required to restore a complete backup—If one file or folder is all you need, Tri–BACKUP lets 
you quickly restore that one item. The most crucial factor here is that you always maintain the same name for your source and destina-
tion folders. If you change either between backups, you may sever the connection between them. Most often, this can be corrected, but 
it’s better to not create the problem at all.

Restoration constraints
During a backup, the contents of each folder are copied into folders with the same names as the originals, from the top level to the low-
est subfolder. The entire backup is contained in a master folder, bearing the same name as the folder or disk being backed up. This rule 
allows for the simple separation of multiple backups in the same destination folder.

For example, take the backup of the hard disk “Macintosh HD” and the folder “Documents” into the folder “BACKUP” on the hard 
disk “Util HD”.

Tri–BACKUP creates two folders inside the “BACKUP” folder—“Macintosh HD” (for the copy of the disk) and “Documents” (for the 
copy of the folder). In order to be able to later restore the original Documents folder or Macintosh HD disk, Tri–BACKUP needs to be 
able to find these two identically-named folders where it expects to find them—inside the destination folder that is supposed to hold the 
backup. For this reason, it is important to NOT rename backup folders or their contents.

Restoring
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Restoration’s powerful possibilities
You can freely choose any folder for restoration, as long as the names match the constraints as detailed.

This translates into very powerful control over the Restore process. For instance, you can restore a subfolder from a backup, or restore 
a folder into any folder, or restore a complete new disk from a backup of your old disk, just by changing either the name of the backup 
folder or of the destination folder, to make them consistent.

Remember that, during a backup, the folder and subfolder structure is conserved. That means that Tri–BACKUP can restore from any 
copy of a folder, including copies made in the Finder, using a Synchronization action, and so on.

The Restore Window
The Restore Window controls the process of restoration, and is opened by clicking the Restore button at the bottom of the main win-
dow. If you select an action before clicking the Restore button, the source and destination folders for the Restore will be preset with 
the parameters of the selected action. You can also drag folders or disks into the destination list and source backup area at the top of 
the Restore Window.

• If you select a destination folder in the upper list, the lower list then displays the contents of the selected item, and compares it to 
the matching contents in the source backup.

• The Display pop-up menu defines whether the comparison list includes all files, only those files missing or modified, or only missing 
files.

• When a file exists in both the backup source and restore destination folders, the modification date is displayed for both files, for 
simple  verification before restoring.
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• If files only exist in the original folder, or in the backup, they are displayed with a specific icon in the center of the list.

Restore list icons include:

 Item to Replace—denotes a file that exists in both destination and source backup, but which has been modified since the last 
backup. A green arrow associated with this icon signifies the file can be restored, replacing the file in the destination with the file 
from the source backup.

 Item not Backed Up—denotes a file which exists in the destination folder, but not in the source backup. This may be a newly cre-
ated document, but it can also be the result of an active filter which excluded the file during backups. If “Allow suppression...” is 
enabled at the bottom of the window, a Trash icon is displayed for this file and it will be deleted from the source backup when the 
action runs.

 Item Missing in the Original Folder—the opposite of the preceding icon. This indicates the file exists in the source backup, but not 
in the destination. This file can be restored.

 Multiple Versions Backed Up—indicates an Evolutive Backup action has stored multiple versions of the same item in the backup. 
The number of available versions is displayed in the list, with the date and size displayed for each. Simply choose the version you 
want to restore before starting the action, turning down the disclosure arrow if necessary to see the versions.

The options at the bottom of the window apply to items that exist only in the original destination folder, and not in the source backup.

• Allow suppression—files missing in the backup will be removed from the destination folder as that folder is restored.

• Including applications, extensions, etc.—this applies the suppression to applications and system files as well as documents.

The Security Folder—Extra Safety in Restoration
Once you have set the various options to your satisfaction, and select the items you wish to restore to their original location, click Re-
store to start the action. In order to allow you the option of undoing a Restore action, Tri–BACKUP copies all of the files that will be 
replaced or deleted into a special security folder at the root of the disk. This security folder is named with the restore date—for example 
“ƒTBUSecure 030912 1427” for a restore executed on September 12, 2003 at 2:27 p.m..

Files saved in the security folder retain their original folder and subfolders structure, which means you can use another Restore action 
to replace these copies in their original locations, should you need to “undo” the last restoration.

Caution: Files may be 
missing from the original 
folder because they were 
filtered during backups. 
Removal of some system 
files can leave your Ma-
cintosh unusable. Use this 
option with great care.



42 Tools Tri–BACKUP 4 User Guide 

The Tools panel provides additional functions which are complementary to the core features of Tri–BACKUP.

Compare Two Disks or Folders
This function compares the contents of two folders or disks, based on the modification dates of the items they contain. You can also 
compare the contents of files, simply by selecting them in the list and clicking Compare.

Partition a Folder’s Content
This function copies the contents of a single folder into multiple subfolders with 
a limited size. The destination subfolders have the same name as the source fold-
er, followed by a number. Use this feature to partition an existing large backup 
into CD-sized folders for burning. You can choose to move the existing files into 
the subfolders, or copy all files, creating both partitioned subfolders and preserv-
ing the original single folder. The option to move the files is faster, especially for 
large folders, but is only available when both source and destination folders are 
on the same volume.

Regroup Folder Contents
The reverse of the partition feature above, this feature regroups the contents of 
multiple folders into one unique folder. You can use it to quickly gather files 
from many diverse folders into one specific one, for organization or archiving. 
You can choose to move the existing files into the subfolders, or copy all files, 
creating both partitioned subfolders and preserving the original single folder. 
The option to move the files is faster, especially for large folders, but is only 
available when both source and destination folders are on the same volume.

Tools
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Modify Properties
Use this feature to modify the owner, creation and modification dates, and vis-
ibility status of files and folders. Once you add a folder or volume to the window, 
you can choose to modify these properties simultaneously for as many files as 
you select in the list. You must be running Tri-BACKUP in Administrator Mode 
in order to modify the owner property.

Check Volume Access
Click this button or choose Tools > Check the Access to a Volume to test access 
to a given volume or server—for example, to verify the settings of a volume to 
be used to create a bootable copy of your hard disk. This feature also verifies 
the correct copy of files’ owner setting, and gives you important information to help understand and resolve errors appearing during a 
backup.

Choose origin and destination disks and click Check. After the test, results are displayed as text that can be selected and copied—for 
example, to send to our technical support department. Included is information about the machine and disks, and the results of file cre-
ation on the destination disk.

Generally, errors are due to problems with:

• Administrator Mode being activated (or not).
• Incorrect access authorization to a server or remote disk.
• Incorrect authorization settings for the destination disk (you can change these in the Finder’s Get Info window).

Information
Also available by choosing Tools > Display Information, two windows are displayed containing information about files, folders and 
disks, to make it easier for you to control their Mac OS X permissions, and to track down the reasons why some operations have failed.

The Information browser window displays lists the items in a folder, their owners, groups and permissions. An error icon is displayed if 
the file cannot be read. Clicking the Information button in the Tools panel opens it to the root level on your hard drive. As usual, double 
clicking folders and disks in the list will open the browser to the next level down. To open the list to a specific folder, select the folder in 
any Tri–BACKUP list and press Command-I. You can also drag a file from the Finder into the opened Information browser window.

The smaller Information window displays more information about the item selected in the Information browser window, or about the 
item selected in any other Tri–BACKUP list.

• Double-click an item in the list to reveal it in the Finder.
• Choose Backup > Export Selection to create a text file listing all selected items.

Caution: Changing the vis-
ibility or owner of files and 
folders in Mac OS X can 
make them inaccessible.
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Latest Files
Click this button, or choose Windows > Show Latest Operations to access a list of the latest 
files copied, organized by the Programmed Actions which created them. Selecting an item 
in the list displays a hierarchical view of its location. Double-clicking the entry reveals the 
item in the Finder.

• Choose Backup > Export Selection to create a text file listing all selected items.
• Type Command-Delete to permanently remove selected files from the list.

Errors
Click this button, or choose Windows > Show Latest Errors, to open the window displaying 
the list of the latest file copy errors, including permissions and owner errors. The list is orga-
nized by the actions which created the errors. Selecting an item in the list displays a hierar-
chical view of its location. Double-clicking the entry reveals the item in the Finder.

• Choose Backup > Export Selection to create a text file listing all selected items.
• Type Command-Delete to permanently remove selected files from the list.

Common Filters
Click this button, or choose Tools > Edit Common Filters, to open the global Filters Editor. Except for the fact that it does not have the 
general option checkboxes at the top, it is identical in form and function to the Filters Editor detailed above under Programmed Actions 
(see Filters Panel on page 36 for more). The difference is that the common filters you define here are accessible to all Programmed 
Actions, simply by clicking a checkbox in the individual Filters Editor. Common Filters should be those that you want applied to most 
actions you create. Filters which will only be suitable for one or two actions should be created in the Filters panels of those actions.

History
Click this button or choose Windows > Show History to re-
veal the Tri–BACKUP History log, showing the list of ac-
tions previously executed, with their name, date and time of 
execution, and results. It the “Create a text log” preference is 
checked, you can also display this file outside of Tri–BACK-
UP.

• Type Command-Delete to permanently remove selected 
files from the list.

Note: The History log is 
cleared as entries “age 
out”. You can set how long 
entries are kept using the 
“Remove from History” set-
ting in Tri–BACKUP Prefer-
ences. The default setting 
is 30 days.
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Browser
Click this button or choose Windows > Show Backup Browser for a quick and easy way to explore the content of your mounted vol-
umes, and to examine the relationship between the files they contain and your Programmed Actions. This is a great tool for checking 
your backup strategy, and for planning new backup actions to cover shortfalls you detect.

The list on the left side displays the contents of your mounted volumes. You can browse through the folders and subfolders as in any 
Mac OS list view. The list on the right displays the Programmed Actions you have created.

The icons next to each item name display their Tri–BACKUP status in relation to the action selected on the right. The marks on the 
action to the right indicate its type.

When you select an action at the right, the icons in the left list indicate which files will be copied or ignored when this action is ex-
ecuted. In the illustration above, the Applications folder is excluded (due to a filter for this folder, as indicated in the status line at the 
bottom right of the window).

When you select a file on the left, icons display which actions are related to the file, and the result icon next to the selected action.

In the illustration above, the Applications folder shows as available to be copied by the “System copy” action on the right, as indicated 
by the checkmark. It will, however, be omitted by the filter, as shown by the icon on the folder, and the status line in the window.
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Search
Choose Tools > Search (Command-F) to search for files on your system from within Tri–BACKUP. Results are displayed in a window 
similar to the Information window.

Create a File to Run Selected Actions
Choose this command from the Actions menu, or type Command-L, to create a separate file on your Macintosh that is linked to the 
currently selected action. When you’ll double-click this file, the action will automatically execute. You can also set an action in the file 
to have Tri–BACKUP quit once the action is completed.

Activate/Deactivate Selected Action(s)
Choose this command from the Backup menu, or  type Command-T, to activate or deactivate the selected action(s)

Compression/Decompression
During a backup action, files can be compressed without changing their file names, then automatically decompressed during restoration 
by Tri–BACKUP. You can also compress or decompresss any file with the Immediate Compress action, and if you double-click a com-
pressed file in the Finder, Tri–BACKUP will launch if necessary and display a dialog proposing to decompress it. Once decompressed, 
the backup file will be replaced by its original version. 

Note: If a file was protected, Tri–BACKUP will ask for the password before recovering the original file.

Evolutive Backup Data
Choose Tools > Evolutive Backup Data to check the size of the evolutive data stored with your backups. You can also choose to make 
this data visible, and “clean” it by deleting the data. If you delete the evolutive data from a backup, it effectively becomes a normal 
Mirror Backup of the original.

Lock Application
Choose Tools > Lock Application or click the Lock button  in the main window to lock or unlock Tri–BACKUP. Once it is locked, 
only the existing Programmed Actions are allowed to be run.

Other Features

Caution: Tri–BACKUP’s 
compression format is 
proprietary. If you remove 
Tri–BACKUP from your sys-
tem, you will not be able 
to recover compressed 
backup files. If a file was 
protected, Tri–BACKUP will 
also ask for the password 
before recovering the 
original file.
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Programmed Actions
In the list of Programmed Actions displayed in the main window, these icons denote the action’s type and status.

 Mirror Backup.
 Incremental Backup.
 Evolutive Backup.
 Synchronization.
 Direct Copy.
 Compression.
 Suppression.

 Next Programmed Action.
 Currently running action.
 Action waiting for execution.
 Activate Administrator authorizations before executing this action.
 Deactivate Administrator authorizations before executing this action.
 Source or destination not defined for this action.

Immediate Actions
In the list of items to be copied by an action, these icons denote how each item will be processed, depending upon the action (copy, 
compress, remove, etc.).

 File to be copied.
 File replacing an older version.
 File replacing a newer version.
 File to be copied.
 File replacing an older version.
 File replacing a newer version.
 File to be compressed.
 File to be decompressed.
 Folder containing files to synchronize (in both ways).

Table of Icons
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 Folder containing files to be copied.
 Folder containing files to be copied.

 Item to be removed.

Restore
These icons denote the status of each item, and are associated with copy/replace icons as detailed above.

 New file (does not exist in the backup).
 Missing file (does not exist in the original disk, only in the backup).

 Modified file (the backup contains another version).
 File having multiple versions in the backup (evolutive backup).

Backup Browser
These icons mark the items which will be processed by the listed Programmed Actions.

 Item is included in one (or more) Programmed Actions (in the left list); or the action marked can process the selected item (in the 
(right list).

 Folder contains items to be processed by one (or more) Programmed Actions.
 Destination of one (or more) Programmed Actions.
 Item will not be processed by the selected Programmed Action (because it is too old, filtered, etc.).

Results and Errors
These icons denote the completion results for each item being processed.

 File copied without error (Immediate Actions).
 Error while copying the file.
 Error while creating the copy of the original file—generally due to a lack of write permissions for the destination folder.
 Error while reading the source file—generally due to a lack of read permissions for the file.
 Error while opening the destination file for writing—generally due to a lack of write permissions for the file.
 Error while reading data in the source file—the file could be damaged.
 Error while writing data to the destination file.
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Q: What is the best backup mode I can choose?

A: It depends on your needs. Read the Different Modes of Backup section.

Q: How can I make a first easy backup of my hard disk?

A: Choose Actions > Immediate Backup or Actions > Immediate Copy. Drag your hard disk icon to the source well at the upper left. 
Drag an external hard disk to the destination well at the upper right. Select all items in the list (Command-A) and click the Backup 
button.

Q: Why was nothing backed up when I ran a backup action?

A: Check your filters to make sure they weren’t set to exclude everything. If your backup is to a server, check that you have the correct 
write permission for it (use the Check button in the Immediate Backup window).

Q: I moved files to the folder I backup, but they are not copied during the backup, why?

A: Check your filters, particularly state of the checkbox marked “Only files modified since the last execution”. If this filter is active,  
files are only copied if they have a modification date later than the last execution of the backup. If the files you add were created or 
modified before that date, they will not be copied.

Q: My backup disk is nearly full. It contains my Evolutive Backup. How can I clean it?

A: Choose Tools > Evolutive Backup Data, select your backup disk or folder, and click the Remove the Data button to remove all 
evolutive data. Note that you can select any individual folder you wish, which means you can clean evolutive data from some folders 
and retain it in others.

If you do not want to avoid having to clean your Evolutive Data manually, open the Options panel for the action and adjust the number 
of versions which are saved by the action, the length of time versions are saved, and/or the number of versions saved for each file.

Q: Sometimes, a file named “TEDEV.TemporaryFile.1247853912” appears and disappears during a backup. What is that file?

A: These are temporary files created by Tri–BACKUP when a file is being copied or compressed. For smaller items, this process can 
happen too quickly to notice; for larger items, the file may exist long enough to be noticed. In either case, Tri–BACKUP deletes these 
temporary files when they are no longer needed.

Q: What are these folders named “(ƒBACKUP.Evolutive.folder**)” on my hard disk?

A: These folders contain the second-level backup data for evolutive backup actions. By default, they are invisible.

Frequently Asked Questions
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Q: How do I make the folders «(ƒBACKUP.Evolutive.folder**)» invisible?

A: Double-click the Evolutive Mirror Backup action in your Programmed Actions list to open it, switch to the Options panel if neces-
sary, and make sure the box marked Visible Folders is NOT checked. Tri–BACKUP will hide the Evolutive Data folders the next time 
the action runs. Their status will be changed during the next backup. If the folders are not made invisible, the data belongs to a different 
action—check your Programmed Actions list for another Evolutive Mirror Backup and repeat the process above.

Q: I lost a document, but I’m sure it’s backed up. How can I recover it easily?

A: The easiest way is to mount your backup volume, search for the file with Sherlock by name, and copy it back to your original folder. 
You can also use the Restore actions in Tri–BACKUP, especially when many files need to be restored. See Different Modes of Restora-
tion on page <> for more.

Q: How do I restore a backup to my hard disk (from a mirror or an evolutive mirror backup)?

A: Select the action used for this backup in the Programmed Actions list, and click the Restore button at the bottom of the list. Select the 
folder or disk to be restored in the top left list, then select the files you wish to restore from the list below, and finally click the Restore 
button to copy the files.

Q: How do I restore a backup to my hard disk (from an incremental backup)?

A: Select the action used for the backup and click the Restore button as in the last example. When the Restore window opens, modify 
the source folder (in the top right well) by dragging your incremental backup folder to it. The folder name should be similar to “ƒTBU2 
01/07/30 08.28.52”. Select the folder or disk to be restored in the top left list, select the files to be restored from the items list below, 
and click Restore. Repeat these steps for each of the incremental backup folders you want to restore.

Q: How do I restore a backup from multiple cartridges or CDs?

A: Select the action used for the backup and click the Restore button as above. If the destination folder is undefined, Tri–BACKUP will 
prompt you to insert a disk. Repeat this process for all of the remaining disks in the backup set.

Q: Is a compressed file automatically decompressed when it is restored?

A: Yes, as long as it is restored with Tri–BACKUP. During the restore process, all compressed files are automatically decompressed 
before being restored. If you restored a compressed file by copying it in the Finder, simply double-click the restored copy to have 
Tri–BACKUP decompress it.

Q: Can I copy or restore a complete Mac OS X bootable volume?

A: Yes, but under Mac OS X, Tri–BACKUP must be consistent with the permissions of the current user, and creating a bootable volume 
requires administrator-level permissions. If you are running Tri–BACKUP in normal user mode, choose Backup > Activate Administra-
tor Mode before continuing.

Q: Yes, but how can I create a bootable copy of a Mac OS X bootable volume?

Preparing the backup to an external hard drive:
• Start your computer using the startup disk you want to backup (using your internal hard disk).
• Login with an administrator account—the first user you created when installing Mac OS X is automatically an administrator.
• Mount your external hard drive, if necessary. It’s a good idea to erase the content of the volume where you will be creating the 

bootable volume, using Apple Disk Utility
• Select the destination disk in the Finder, choose File > Get Info, switch to the Ownership and Permissions panel, and look for the 

checkbox labelled “Ignore ownership on this volume.” If you are using Mac OS X 10.2 or later, ensure this box is not checked. If 
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you are using Mac OS X 10.1, ensure this box is checked.
• Launch Tri–BACKUP and ensure that Administrator Mode is activated (the red bullet icon will be displayed at the top of the main 

window).

Executing the backup:
• In the Immediate Actions panel of the main window, click Copy a Disk or Folder’s Contents.
• Drag your source hard disk volume to the left well.
• Drag your destination hard disk volume to the right well.
• Click the Copy button.
For a large volume, this backup can take considerable time. When it is complete, attempt to use the backup destination volume as your 
startup disk (Use the Startup Disk pane in Apple’s System Preferences). It’s a good idea to run Disk Utility to check and repair the 
permissions on the backup copy as well.

Q: Are owner, group and permission settings preserved during a backup?

A: As long as Administrator Mode is activated, Tri–BACKUP will preserve this information on each file copied.

Q: Are all files copied?

A: Subject to permission limitations of the files and destination folder, yes.

Q: Why are some files not copied?

A: For those cases marked with the error (ERR) icons, permission issues are generally to blame. Other possibilities include items being 
excluded by filters, being the wrong type (applications not copied when “Documents only” was selected), and files which were already 
opened by another application when the action was running.

Q: How can I easily check to ensure that all files were copied?

A: Use Immediate Actions to view all files which are missing or different between source and destination.

Q: How can I choose an invisible file or folder in the select dialog?

A: Option-click the well or button to display the Open dialog with  invisible items showing.

Q: Why is a server not accessible if Administrator Mode is activated?

A: When you activate Administrator Mode, you are in effect telling your system that the current user of Tri–BACKUP is the system 
administrator “root,” also known as the “superuser.” While “root” has full permissions on the local computer drives, the “superuser” 
does have one Achilles’ heel— “root has no permissions for remote servers. For this reason, you must always deactivate Administrator 
Mode to access a server.

Q: Why is the owner of a file changed when the file is copied to a remote disk?

A: The owner of a file is actually identified by an ID number. For example, the first user created on a Mac OS X system is usually given 
the ID number 501. Tri–BACKUP preserves the owner ID number as it copies files, so if the number is in use by a different user on the 
destination volume, the owner may change.


	Cover
	Legal Notices
	Table of Contents
	Contents

	Introduction
	Welcome!
	Thank you for registering
	Installation
	Updates 
	Updating to version 4.x
	Upgrade from version 3 or 2

	Uninstalling
	Launching and Registering the Software
	Technical support 
	Contact TRI-EDRE

	Administrator Mode (Mac OS X only)
	Activating Administrator Mode

	Basics
	Actions—Immediate vs. Programmed
	Immediate Actions
	Programmed Actions

	What can be backed up or synchronized?
	Complete Automation
	Normal Operation
	Backup
	Backup Destination
	Copying
	Restoring 
	Synchronizing
	Multiple configurations

	Backup Strategies
	What kind of backup to use?
	Background Backups
	Create configurations for every backup

	Backup of several computers over the network
	Backup / Restore / Source / Origin / Destination
	Back up your backup!

	Backup Modes
	Finder Backup
	Synchronization
	Immediate Backup
	Programmed Mirror Backup
	Programmed Evolutive Mirror Backup
	Programmed Incremental Backup

	Restore Modes
	Manual Restoration from the Finder
	Using Synchronization to Restore
	Using Immediate Restoration
	Using the Programmed Actions Restore button

	The Main Window
	Assistant
	Immediate Actions
	Programmed Actions
	Groups of Programmed Actions
	Controls

	Tools
	Action Progress window


	Preferences
	Immediate Actions
	Actions Menu vs. Main Window
	Common Immediate Actions Settings
	Filter Settings
	Choosing Folders and Disks
	Display options

	Immediate Backup
	Running a Backup
	Checking First

	Immediate Restore
	Immediate Copy
	Immediate Synchronization
	Immediate Compression/Decompression/Protection
	Delete a Disk or Folder’s Contents

	Programmed Actions
	Creating a Programmed Action
	Mode Panel
	Title
	Group
	Mode menu
	Administrator Mode (Mac OS X only)

	Items Panel
	About unmounted volumes

	Options panel
	Alert and Launch of File or Script
	Direct Copy
	Mirror Backup
	Evolutive Mirror Backup
	Incremental Backup
	Synchronization
	Compress/Decompress
	Delete

	Trigger Panel
	The Filters Panel
	Predefined Filters
	Specific Filters List
	Filters Editor

	Links Panel


	Restoring
	Restoration constraints
	Restoration’s powerful possibilities
	The Restore Window
	The Security Folder—Extra Safety in Restoration

	Tools
	Compare Two Disks or Folders
	Partition a Folder’s Content
	Regroup Folder Contents
	Modify Properties
	Check Volume Access
	Information
	Latest Files
	Errors
	Common Filters
	History
	Browser

	Other Features
	Search
	Create a File to Run Selected Actions
	Activate/Deactivate Selected Action(s)
	Compression/Decompression
	Evolutive Backup Data
	Lock Application

	Table of Icons
	Programmed Actions
	Immediate Actions
	Restore
	Backup Browser
	Results and Errors

	Frequently Asked Questions

